Muitas pessoas sabem como fazer a relação de maior, menor, igual ou diferente entre dois números ou duas funções no Excel, porém como fazer essas comparações de critérios com SOMASE no Excel?

Sabemos que:

= (igual) Usamos quando queremos fazer um teste lógico com números iguais.

> (maior) – Números maiores estarão à esquerda do símbolo.

< (menor) – Números menores estarão à esquerda do símbolo.

<> (diferente) – Usa-se os símbolos de menor e maior um ao lado do outro, nesta ordem.

 

Leia aqui uma explicação completa sobre os símbolos de maior menor, maior igual, diferente no Excel.

 

Exemplo 1:

Após definir as células que serão utilizadas na fórmula, adiciona-se o símbolo escolhido dentre as referências

O símbolo escolhido é o maior. A fórmula na célula B4 é:

=SE(A2>B2;"Maior";"Menor")

Veja outros exemplos:

=SE(A2<B2;"Menor";"Maior")
=SE(A2=B2;"Igual";"Diferente")
=SE(A2<>B2;"Diferente";"Igual")

SOMASE com Critérios

Outro tipo de aplicação usado é quando utiliza-se SOMASE no Excel combinado com um critério é maior, menor, igual ou diferente. Deve-se colocar o símbolo e o número entre aspas (“”).

 

 

 

 

 

 


=SOMASE(A2:A10;">0")

Veja que o critério está definido como “>0”, ou seja, resultará na soma se os valores forem maiores que zero.

Para qualquer símbolo usado nesta situação use aspas.

Exemplo 3:

 

 

 

 

 

 

 

 

Esta planilha mostra uma seleção de números aleatórios, positivos e negativos.

O critério para o SOMASE será todos os números maiores que zero. Desta vez não o zero não entra direto na fórmula, mas como referência na célula D1.

 

Confira algumas dicas para não errar no =SOMASE do Excel

Dica #1 – Use aspas em critérios maior, menor, diferente

=SOMASE(A2:A10;>D1)

Certo? Não!

Ao terminar a fórmula, o Excel indica um erro.

OK, então vamos colocar aspas.

 

Dica #2 – Se usou aspas, precisa “juntar” com a célula

=SOMASE(A2:A10;">D1")

Desta vez o Excel não indicou erro algum, porém não funcionou. O resultado do SOMASE Excel retornou ZERO.

Mais um situação errada:

 

Dica #3 – Mas não esqueça do & (CONCATENAR) 

=SOMASE(A2:A10;">"D1)

Nesta situação deve-se usar o “e” comercial, &. Dentro de uma fórmula no Excel, ele serve como a função CONCATENAR.

E finalmente, o correto é:

 

=SOMASE(A2:A10;”>”&D1)

 

E então:

 

 

 

 

 

 

 

Quando digita-se “>”&D1 o Excel detecta qual é o valor contido na célula D1 e então o joga “para dentro” das aspas. Cria-se esta situação.

=SOMASE(A2:A10;">0")

Não esqueça que para todos os exemplos podemos usar maior, menor, igual ou o diferente no Excel.

 

 

Cássio NetoDicasexcel,planilhaMuitas pessoas sabem como fazer a relação de maior, menor, igual ou diferente entre dois números ou duas funções no Excel, porém como fazer essas comparações de critérios com SOMASE no Excel? Sabemos que: = (igual) - Usamos quando queremos fazer um teste lógico com números iguais. > (maior) - Números maiores estarão...Curso Excel Avançado - Joinville, Curso Excel Avançado Online, Dicas de Excel